Learn to Code While Building Apps - The Complete Flutter Development Bootcamp

Overview

Flutter-Course-Resources

Section 1: Introduction to Cross-Platform Development with Flutter and Dart

Section 2: Setting Up for Flutter Development

Section 3: I Am Rich - How to Create Flutter Apps from Scratch

Section 4: Running Your App on a Physical Device

Section 5: I Am Poor - App Challenge

Section 6: MiCard - How to Build Beautiful UIs with Flutter Widgets

Section 7: Dicee - Building Apps with State

Section 8: Boss Level Challenge 1 - Magic 8 Ball

Section 9: Xylophone - Using Flutter and Dart Packages to Speed Up Development

Section 10: Quizzler - Modularising & Organising Flutter Code

Section 11: Boss Level Challenge 2 - Destini

Section 12: BMI Calculator - Building Flutter UIs for Intermediates

Section 13: Clima - Powering Your Flutter App with Live Weather Web Data

Section 14: Boss Level Challenge 3 - Bitcoin Ticker (a.k.a. Am I Rich?)

Section 15: Flash Chat - Flutter x Firebase Cloud Firestore

Section 16: Flutter State Management

Comments
  • I am getting this issue, and I have no idea how this will be resolved.

    I am getting this issue, and I have no idea how this will be resolved.

    Invalid depfile: C:\Users\Ajeet Chaurasia\AndroidStudioProjects\my_card.dart_tool\flutter_build\2c96f7b7ab065ed1d5c4586aab33f984\kernel_snapshot.d

    Screenshot: https://screenrec.com/share/meFCf8rk9h

    opened by ajeetkumar955 4
  • Add StateManagementExample project to section 16

    Add StateManagementExample project to section 16

    • The StateManagementExample project is not available in the README.md file so I added it by a search for the repo in the profile.
    • It will be easier for future students to look up rather than searching for it.
    opened by gupta-shrinath 3
  • Section 16's 218 introducing the provider package demo is missing from download

    Section 16's 218 introducing the provider package demo is missing from download

    Hi there, first of all thanks for the awesome course!

    But as the title stated, the demo Angela was using to demonstrate the topic was missing from download, and... will it be listed? Hope it will, and I'm pretty sure that Angela was saying we can download it from the resource listed in here, I think.

    Anyway, thanks!😊

    opened by SeasonLeee 3
  • Clone Failed Could not resolve Hostname

    Clone Failed Could not resolve Hostname

    1. I cannot get Android studio to Paste.
    2. When I type in the URL specified for the mi_card_flutter.git. I get a message that clone failed. Could not resolve hostname. A mi_card_flutter is created but only contains Idea folder and readme file

    I am using Windows 10.

    opened by Sassyone491 2
  • Flutter doctor

    Flutter doctor

    Unable to locate a development device; run 'flutter doctor' I have run flutter doctor on terminal and it says Android sdk file not found Pls help me __ Uploading IMG_20200603_174033.jpg…

    opened by kelvin002a 2
  • 13. Flutter State Management - Step 1 - Stub Project doesn't exist

    13. Flutter State Management - Step 1 - Stub Project doesn't exist

    In the course resource main page the link for the stub projet in the final module (13. Flutter State Management) points to the completed project, not the stub project.

    opened by jaredbaszler 2
  • Section6 Video2 code Confusion

    Section6 Video2 code Confusion

    Thanks for the amazing lecture. When I was watching Section 6 Hot Reload and Hot Restart, the sample code suddenly changed from using stateless widget to stateful widget after a few slides, which is kind of confusing. What is the difference between those two and when should we use them?

    opened by yueli96 1
  • Quizzler Flutter Challenge Typo

    Quizzler Flutter Challenge Typo

    In quiz_brain.dart there seems to be a typo in the TODO: steps. "Step 4 Part A" should be "Step 4 Part B" instead.

    main.dart:

    //TODO: Step 4 - Use IF/ELSE to check if we've reached the end of the quiz. If true, execute Part A, B, C, D.
    //TODO: Step 4 Part A - show an alert using rFlutter_alert (remember to read the docs for the package!)
    //HINT! Step 4 Part B is in the quiz_brain.dart
    //TODO: Step 4 Part C - reset the questionNumber,
    //TODO: Step 4 Part D - empty out the scoreKeeper.
    //TODO: Step 5 - If we've not reached the end, ELSE do the answer checking steps below 👇
    

    quiz_brain.dart:

    //TODO: Step 3 Part B - Use a print statement to check that isFinished is returning true when you are indeed at the end of the quiz and when a restart should happen.
    //TODO: Step 4 Part A - Create a reset() method here that sets the questionNumber back to 0.
    
    opened by jaredbaszler 1
  • Update 31 links to their new location

    Update 31 links to their new location

    Change all links from 'docs.flutter.io' which is "Not Found" to 'api.flutter.dev' which is relevant

    link with 'docs.flutter.io' Screenshot from 2022-07-03 09-28-43

    link with 'api.flutter.dev' Screenshot from 2022-07-03 09-30-29

    opened by VukolRo 0
  • Update README.md

    Update README.md

    there were a lot of links from flutter.io which didn't work, i find relevant links in flutter.dev and change them. But there are still many which don't have same naming e.g. Slider-class

    opened by VukolRo 0
  • Exception: Gradle task assembleDebug failed ) exit code 1

    Exception: Gradle task assembleDebug failed ) exit code 1

    when i start my emulator the following error is shown

    Launching lib\main.dart on Android SDK built for x86 in debug mode... Running Gradle task 'assembleDebug'...

    FAILURE: Build failed with an exception.

    • What went wrong: A problem occurred configuring root project 'android'.

    Could not resolve all artifacts for configuration ':classpath'. Could not resolve com.android.tools.build:gradle-api:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.lint:lint-gradle-api:26.5.0 > Could not resolve com.android.tools.build:gradle-api:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle-api/3.5.0/gradle-api-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle-api/3.5.0/gradle-api-3.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:gradle-api:3.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/gradle-api/3.5.0/gradle-api-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/gradle-api/3.5.0/gradle-api-3.5.0.pom'. > jcenter.bintray.com Could not resolve org.ow2.asm:asm:6.0. Required by: project : > com.android.tools.build:gradle:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve org.ow2.asm:asm:6.0. > Could not get resource 'https://jcenter.bintray.com/org/ow2/asm/asm/6.0/asm-6.0.pom'. > Could not HEAD 'https://jcenter.bintray.com/org/ow2/asm/asm/6.0/asm-6.0.pom'. > jcenter.bintray.com > Could not resolve org.ow2.asm:asm:6.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm/6.0/asm-6.0.pom'. > Could not HEAD 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm/6.0/asm-6.0.pom'. > dl.google.com Could not resolve org.ow2.asm:asm-analysis:6.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > Could not resolve org.ow2.asm:asm-analysis:6.0. > Could not get resource 'https://jcenter.bintray.com/org/ow2/asm/asm-analysis/6.0/asm-analysis-6.0.pom'. > Could not HEAD 'https://jcenter.bintray.com/org/ow2/asm/asm-analysis/6.0/asm-analysis-6.0.pom'. > jcenter.bintray.com > Could not resolve org.ow2.asm:asm-analysis:6.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-analysis/6.0/asm-analysis-6.0.pom'. > Could not HEAD 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-analysis/6.0/asm-analysis-6.0.pom'. > dl.google.com Could not resolve org.ow2.asm:asm-commons:6.0. Required by: project : > com.android.tools.build:gradle:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve org.ow2.asm:asm-commons:6.0. > Could not get resource 'https://jcenter.bintray.com/org/ow2/asm/asm-commons/6.0/asm-commons-6.0.pom'. > Could not HEAD 'https://jcenter.bintray.com/org/ow2/asm/asm-commons/6.0/asm-commons-6.0.pom'. > jcenter.bintray.com > Could not resolve org.ow2.asm:asm-commons:6.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-commons/6.0/asm-commons-6.0.pom'. > Could not HEAD 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-commons/6.0/asm-commons-6.0.pom'. > dl.google.com Could not resolve org.ow2.asm:asm-util:6.0. Required by: project : > com.android.tools.build:gradle:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve org.ow2.asm:asm-util:6.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-util/6.0/asm-util-6.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-util/6.0/asm-util-6.0.pom'. > dl.google.com > Could not resolve org.ow2.asm:asm-util:6.0. > Could not get resource 'https://jcenter.bintray.com/org/ow2/asm/asm-util/6.0/asm-util-6.0.pom'. > Could not GET 'https://jcenter.bintray.com/org/ow2/asm/asm-util/6.0/asm-util-6.0.pom'. > jcenter.bintray.com Could not resolve net.sf.jopt-simple:jopt-simple:4.9. Required by: project : > com.android.tools.build:gradle:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve net.sf.jopt-simple:jopt-simple:4.9. > Could not get resource 'https://dl.google.com/dl/android/maven2/net/sf/jopt-simple/jopt-simple/4.9/jopt-simple-4.9.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/net/sf/jopt-simple/jopt-simple/4.9/jopt-simple-4.9.pom'. > dl.google.com > Could not resolve net.sf.jopt-simple:jopt-simple:4.9. > Could not get resource 'https://jcenter.bintray.com/net/sf/jopt-simple/jopt-simple/4.9/jopt-simple-4.9.pom'. > Could not GET 'https://jcenter.bintray.com/net/sf/jopt-simple/jopt-simple/4.9/jopt-simple-4.9.pom'. > jcenter.bintray.com Could not resolve net.sf.proguard:proguard-gradle:6.0.3. Required by: project : > com.android.tools.build:gradle:3.5.0 > Could not resolve net.sf.proguard:proguard-gradle:6.0.3. > Could not get resource 'https://dl.google.com/dl/android/maven2/net/sf/proguard/proguard-gradle/6.0.3/proguard-gradle-6.0.3.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/net/sf/proguard/proguard-gradle/6.0.3/proguard-gradle-6.0.3.pom'. > dl.google.com > Could not resolve net.sf.proguard:proguard-gradle:6.0.3. > Could not get resource 'https://jcenter.bintray.com/net/sf/proguard/proguard-gradle/6.0.3/proguard-gradle-6.0.3.pom'. > Could not GET 'https://jcenter.bintray.com/net/sf/proguard/proguard-gradle/6.0.3/proguard-gradle-6.0.3.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build:bundletool:0.9.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > Could not resolve com.android.tools.build:bundletool:0.9.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/bundletool/0.9.0/bundletool-0.9.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/bundletool/0.9.0/bundletool-0.9.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:bundletool:0.9.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/bundletool/0.9.0/bundletool-0.9.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/bundletool/0.9.0/bundletool-0.9.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build.jetifier:jetifier-core:1.0.0-beta04. Required by: project : > com.android.tools.build:gradle:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.android.tools.build.jetifier:jetifier-core:1.0.0-beta04. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/jetifier/jetifier-core/1.0.0-beta04/jetifier-core-1.0.0-beta04.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/jetifier/jetifier-core/1.0.0-beta04/jetifier-core-1.0.0-beta04.pom'. > dl.google.com > Could not resolve com.android.tools.build.jetifier:jetifier-core:1.0.0-beta04. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/jetifier/jetifier-core/1.0.0-beta04/jetifier-core-1.0.0-beta04.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/jetifier/jetifier-core/1.0.0-beta04/jetifier-core-1.0.0-beta04.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build.jetifier:jetifier-processor:1.0.0-beta04. Required by: project : > com.android.tools.build:gradle:3.5.0 > Could not resolve com.android.tools.build.jetifier:jetifier-processor:1.0.0-beta04. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/jetifier/jetifier-processor/1.0.0-beta04/jetifier-processor-1.0.0-beta04.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/jetifier/jetifier-processor/1.0.0-beta04/jetifier-processor-1.0.0-beta04.pom'. > dl.google.com > Could not resolve com.android.tools.build.jetifier:jetifier-processor:1.0.0-beta04. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/jetifier/jetifier-processor/1.0.0-beta04/jetifier-processor-1.0.0-beta04.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/jetifier/jetifier-processor/1.0.0-beta04/jetifier-processor-1.0.0-beta04.pom'. > jcenter.bintray.com Could not resolve com.google.protobuf:protobuf-java:3.4.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > Could not resolve com.google.protobuf:protobuf-java:3.4.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/google/protobuf/protobuf-java/3.4.0/protobuf-java-3.4.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/google/protobuf/protobuf-java/3.4.0/protobuf-java-3.4.0.pom'. > dl.google.com > Could not resolve com.google.protobuf:protobuf-java:3.4.0. > Could not get resource 'https://jcenter.bintray.com/com/google/protobuf/protobuf-java/3.4.0/protobuf-java-3.4.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/google/protobuf/protobuf-java/3.4.0/protobuf-java-3.4.0.pom'. > jcenter.bintray.com Could not resolve com.google.protobuf:protobuf-java-util:3.4.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > Could not resolve com.google.protobuf:protobuf-java-util:3.4.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/google/protobuf/protobuf-java-util/3.4.0/protobuf-java-util-3.4.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/google/protobuf/protobuf-java-util/3.4.0/protobuf-java-util-3.4.0.pom'. > dl.google.com > Could not resolve com.google.protobuf:protobuf-java-util:3.4.0. > Could not get resource 'https://jcenter.bintray.com/com/google/protobuf/protobuf-java-util/3.4.0/protobuf-java-util-3.4.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/google/protobuf/protobuf-java-util/3.4.0/protobuf-java-util-3.4.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build:builder-model:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.lint:lint-gradle-api:26.5.0 > Could not resolve com.android.tools.build:builder-model:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/builder-model/3.5.0/builder-model-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/builder-model/3.5.0/builder-model-3.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:builder-model:3.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/builder-model/3.5.0/builder-model-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/builder-model/3.5.0/builder-model-3.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build:builder-test-api:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.build:builder-test-api:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/builder-test-api/3.5.0/builder-test-api-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/builder-test-api/3.5.0/builder-test-api-3.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:builder-test-api:3.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/builder-test-api/3.5.0/builder-test-api-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/builder-test-api/3.5.0/builder-test-api-3.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools:sdklib:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.lint:lint-gradle-api:26.5.0 > Could not resolve com.android.tools:sdklib:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/sdklib/26.5.0/sdklib-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/sdklib/26.5.0/sdklib-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools:sdklib:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/sdklib/26.5.0/sdklib-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/sdklib/26.5.0/sdklib-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools:sdk-common:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools:sdk-common:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/sdk-common/26.5.0/sdk-common-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/sdk-common/26.5.0/sdk-common-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools:sdk-common:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/sdk-common/26.5.0/sdk-common-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/sdk-common/26.5.0/sdk-common-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools:common:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools:common:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/common/26.5.0/common-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/common/26.5.0/common-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools:common:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/common/26.5.0/common-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/common/26.5.0/common-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build:manifest-merger:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.build:manifest-merger:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/manifest-merger/26.5.0/manifest-merger-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/manifest-merger/26.5.0/manifest-merger-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:manifest-merger:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/manifest-merger/26.5.0/manifest-merger-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/manifest-merger/26.5.0/manifest-merger-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.ddms:ddmlib:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.ddms:ddmlib:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/ddms/ddmlib/26.5.0/ddmlib-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/ddms/ddmlib/26.5.0/ddmlib-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.ddms:ddmlib:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/ddms/ddmlib/26.5.0/ddmlib-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/ddms/ddmlib/26.5.0/ddmlib-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.analytics-library:protos:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.analytics-library:protos:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/analytics-library/protos/26.5.0/protos-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/analytics-library/protos/26.5.0/protos-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.analytics-library:protos:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/analytics-library/protos/26.5.0/protos-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/analytics-library/protos/26.5.0/protos-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.analytics-library:tracker:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.analytics-library:tracker:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/analytics-library/tracker/26.5.0/tracker-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/analytics-library/tracker/26.5.0/tracker-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.analytics-library:tracker:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/analytics-library/tracker/26.5.0/tracker-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/analytics-library/tracker/26.5.0/tracker-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build:apksig:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.build:apksig:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/apksig/3.5.0/apksig-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/apksig/3.5.0/apksig-3.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:apksig:3.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/apksig/3.5.0/apksig-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/apksig/3.5.0/apksig-3.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.tools.build:apkzlib:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.android.tools.build:apkzlib:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/apkzlib/3.5.0/apkzlib-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/apkzlib/3.5.0/apkzlib-3.5.0.pom'. > dl.google.com > Could not resolve com.android.tools.build:apkzlib:3.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/apkzlib/3.5.0/apkzlib-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/apkzlib/3.5.0/apkzlib-3.5.0.pom'. > jcenter.bintray.com Could not resolve com.squareup:javawriter:2.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.squareup:javawriter:2.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/squareup/javawriter/2.5.0/javawriter-2.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/squareup/javawriter/2.5.0/javawriter-2.5.0.pom'. > dl.google.com > Could not resolve com.squareup:javawriter:2.5.0. > Could not get resource 'https://jcenter.bintray.com/com/squareup/javawriter/2.5.0/javawriter-2.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/squareup/javawriter/2.5.0/javawriter-2.5.0.pom'. > jcenter.bintray.com Could not resolve org.bouncycastle:bcpkix-jdk15on:1.56. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve org.bouncycastle:bcpkix-jdk15on:1.56. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/bouncycastle/bcpkix-jdk15on/1.56/bcpkix-jdk15on-1.56.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/bouncycastle/bcpkix-jdk15on/1.56/bcpkix-jdk15on-1.56.pom'. > dl.google.com > Could not resolve org.bouncycastle:bcpkix-jdk15on:1.56. > Could not get resource 'https://jcenter.bintray.com/org/bouncycastle/bcpkix-jdk15on/1.56/bcpkix-jdk15on-1.56.pom'. > Could not GET 'https://jcenter.bintray.com/org/bouncycastle/bcpkix-jdk15on/1.56/bcpkix-jdk15on-1.56.pom'. > jcenter.bintray.com Could not resolve org.bouncycastle:bcprov-jdk15on:1.56. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve org.bouncycastle:bcprov-jdk15on:1.56. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/bouncycastle/bcprov-jdk15on/1.56/bcprov-jdk15on-1.56.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/bouncycastle/bcprov-jdk15on/1.56/bcprov-jdk15on-1.56.pom'. > dl.google.com > Could not resolve org.bouncycastle:bcprov-jdk15on:1.56. > Could not get resource 'https://jcenter.bintray.com/org/bouncycastle/bcprov-jdk15on/1.56/bcprov-jdk15on-1.56.pom'. > Could not GET 'https://jcenter.bintray.com/org/bouncycastle/bcprov-jdk15on/1.56/bcprov-jdk15on-1.56.pom'. > jcenter.bintray.com Could not resolve org.ow2.asm:asm-tree:6.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve org.ow2.asm:asm-tree:6.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-tree/6.0/asm-tree-6.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/ow2/asm/asm-tree/6.0/asm-tree-6.0.pom'. > dl.google.com > Could not resolve org.ow2.asm:asm-tree:6.0. > Could not get resource 'https://jcenter.bintray.com/org/ow2/asm/asm-tree/6.0/asm-tree-6.0.pom'. > Could not GET 'https://jcenter.bintray.com/org/ow2/asm/asm-tree/6.0/asm-tree-6.0.pom'. > jcenter.bintray.com Could not resolve javax.inject:javax.inject:1. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve javax.inject:javax.inject:1. > Could not get resource 'https://dl.google.com/dl/android/maven2/javax/inject/javax.inject/1/javax.inject-1.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/javax/inject/javax.inject/1/javax.inject-1.pom'. > dl.google.com > Could not resolve javax.inject:javax.inject:1. > Could not get resource 'https://jcenter.bintray.com/javax/inject/javax.inject/1/javax.inject-1.pom'. > Could not GET 'https://jcenter.bintray.com/javax/inject/javax.inject/1/javax.inject-1.pom'. > jcenter.bintray.com Could not resolve it.unimi.dsi:fastutil:7.2.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve it.unimi.dsi:fastutil:7.2.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/it/unimi/dsi/fastutil/7.2.0/fastutil-7.2.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/it/unimi/dsi/fastutil/7.2.0/fastutil-7.2.0.pom'. > dl.google.com > Could not resolve it.unimi.dsi:fastutil:7.2.0. > Could not get resource 'https://jcenter.bintray.com/it/unimi/dsi/fastutil/7.2.0/fastutil-7.2.0.pom'. > Could not GET 'https://jcenter.bintray.com/it/unimi/dsi/fastutil/7.2.0/fastutil-7.2.0.pom'. > jcenter.bintray.com Could not resolve com.googlecode.json-simple:json-simple:1.1. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.build:builder:3.5.0 > Could not resolve com.googlecode.json-simple:json-simple:1.1. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/googlecode/json-simple/json-simple/1.1/json-simple-1.1.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/googlecode/json-simple/json-simple/1.1/json-simple-1.1.pom'. > dl.google.com > Could not resolve com.googlecode.json-simple:json-simple:1.1. > Could not get resource 'https://jcenter.bintray.com/com/googlecode/json-simple/json-simple/1.1/json-simple-1.1.pom'. > Could not GET 'https://jcenter.bintray.com/com/googlecode/json-simple/json-simple/1.1/json-simple-1.1.pom'. > jcenter.bintray.com Could not resolve com.android.tools:annotations:26.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.analytics-library:crash:26.5.0 project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.android.tools:annotations:26.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/annotations/26.5.0/annotations-26.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/annotations/26.5.0/annotations-26.5.0.pom'. > dl.google.com > Could not resolve com.android.tools:annotations:26.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/tools/annotations/26.5.0/annotations-26.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/tools/annotations/26.5.0/annotations-26.5.0.pom'. > jcenter.bintray.com Could not resolve com.google.guava:guava:27.0.1-jre. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.analytics-library:crash:26.5.0 project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.lint:lint-gradle-api:26.5.0 project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.google.guava:guava:27.0.1-jre. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/google/guava/guava/27.0.1-jre/guava-27.0.1-jre.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/google/guava/guava/27.0.1-jre/guava-27.0.1-jre.pom'. > dl.google.com > Could not resolve com.google.guava:guava:27.0.1-jre. > Could not get resource 'https://jcenter.bintray.com/com/google/guava/guava/27.0.1-jre/guava-27.0.1-jre.pom'. > Could not GET 'https://jcenter.bintray.com/com/google/guava/guava/27.0.1-jre/guava-27.0.1-jre.pom'. > jcenter.bintray.com Could not resolve org.apache.httpcomponents:httpmime:4.5.6. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.analytics-library:crash:26.5.0 > Could not resolve org.apache.httpcomponents:httpmime:4.5.6. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/apache/httpcomponents/httpmime/4.5.6/httpmime-4.5.6.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/apache/httpcomponents/httpmime/4.5.6/httpmime-4.5.6.pom'. > dl.google.com > Could not resolve org.apache.httpcomponents:httpmime:4.5.6. > Could not get resource 'https://jcenter.bintray.com/org/apache/httpcomponents/httpmime/4.5.6/httpmime-4.5.6.pom'. > Could not GET 'https://jcenter.bintray.com/org/apache/httpcomponents/httpmime/4.5.6/httpmime-4.5.6.pom'. > jcenter.bintray.com Could not resolve org.apache.httpcomponents:httpcore:4.4.10. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.analytics-library:crash:26.5.0 > Could not resolve org.apache.httpcomponents:httpcore:4.4.10. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/apache/httpcomponents/httpcore/4.4.10/httpcore-4.4.10.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/apache/httpcomponents/httpcore/4.4.10/httpcore-4.4.10.pom'. > dl.google.com > Could not resolve org.apache.httpcomponents:httpcore:4.4.10. > Could not get resource 'https://jcenter.bintray.com/org/apache/httpcomponents/httpcore/4.4.10/httpcore-4.4.10.pom'. > Could not GET 'https://jcenter.bintray.com/org/apache/httpcomponents/httpcore/4.4.10/httpcore-4.4.10.pom'. > jcenter.bintray.com Could not resolve org.apache.httpcomponents:httpclient:4.5.6. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.analytics-library:crash:26.5.0 > Could not resolve org.apache.httpcomponents:httpclient:4.5.6. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/apache/httpcomponents/httpclient/4.5.6/httpclient-4.5.6.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/apache/httpcomponents/httpclient/4.5.6/httpclient-4.5.6.pom'. > dl.google.com > Could not resolve org.apache.httpcomponents:httpclient:4.5.6. > Could not get resource 'https://jcenter.bintray.com/org/apache/httpcomponents/httpclient/4.5.6/httpclient-4.5.6.pom'. > Could not GET 'https://jcenter.bintray.com/org/apache/httpcomponents/httpclient/4.5.6/httpclient-4.5.6.pom'. > jcenter.bintray.com Could not resolve org.jetbrains.kotlin:kotlin-reflect:1.3.41. Required by: project : > com.android.tools.build:gradle:3.5.0 > com.android.tools.lint:lint-gradle-api:26.5.0 > Could not resolve org.jetbrains.kotlin:kotlin-reflect:1.3.41. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-reflect/1.3.41/kotlin-reflect-1.3.41.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-reflect/1.3.41/kotlin-reflect-1.3.41.pom'. > dl.google.com > Could not resolve org.jetbrains.kotlin:kotlin-reflect:1.3.41. > Could not get resource 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-reflect/1.3.41/kotlin-reflect-1.3.41.pom'. > Could not GET 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-reflect/1.3.41/kotlin-reflect-1.3.41.pom'. > jcenter.bintray.com Could not resolve androidx.databinding:databinding-common:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve androidx.databinding:databinding-common:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/androidx/databinding/databinding-common/3.5.0/databinding-common-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/androidx/databinding/databinding-common/3.5.0/databinding-common-3.5.0.pom'. > dl.google.com > Could not resolve androidx.databinding:databinding-common:3.5.0. > Could not get resource 'https://jcenter.bintray.com/androidx/databinding/databinding-common/3.5.0/databinding-common-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/androidx/databinding/databinding-common/3.5.0/databinding-common-3.5.0.pom'. > jcenter.bintray.com Could not resolve com.android.databinding:baseLibrary:3.5.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.android.databinding:baseLibrary:3.5.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/databinding/baseLibrary/3.5.0/baseLibrary-3.5.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/databinding/baseLibrary/3.5.0/baseLibrary-3.5.0.pom'. > dl.google.com > Could not resolve com.android.databinding:baseLibrary:3.5.0. > Could not get resource 'https://jcenter.bintray.com/com/android/databinding/baseLibrary/3.5.0/baseLibrary-3.5.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/android/databinding/baseLibrary/3.5.0/baseLibrary-3.5.0.pom'. > jcenter.bintray.com Could not resolve org.antlr:antlr4:4.5.3. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve org.antlr:antlr4:4.5.3. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/antlr/antlr4/4.5.3/antlr4-4.5.3.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/antlr/antlr4/4.5.3/antlr4-4.5.3.pom'. > dl.google.com > Could not resolve org.antlr:antlr4:4.5.3. > Could not get resource 'https://jcenter.bintray.com/org/antlr/antlr4/4.5.3/antlr4-4.5.3.pom'. > Could not GET 'https://jcenter.bintray.com/org/antlr/antlr4/4.5.3/antlr4-4.5.3.pom'. > jcenter.bintray.com Could not resolve commons-io:commons-io:2.4. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve commons-io:commons-io:2.4. > Could not get resource 'https://dl.google.com/dl/android/maven2/commons-io/commons-io/2.4/commons-io-2.4.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/commons-io/commons-io/2.4/commons-io-2.4.pom'. > dl.google.com > Could not resolve commons-io:commons-io:2.4. > Could not get resource 'https://jcenter.bintray.com/commons-io/commons-io/2.4/commons-io-2.4.pom'. > Could not GET 'https://jcenter.bintray.com/commons-io/commons-io/2.4/commons-io-2.4.pom'. > jcenter.bintray.com Could not resolve com.googlecode.juniversalchardet:juniversalchardet:1.0.3. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.googlecode.juniversalchardet:juniversalchardet:1.0.3. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/googlecode/juniversalchardet/juniversalchardet/1.0.3/juniversalchardet-1.0.3.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/googlecode/juniversalchardet/juniversalchardet/1.0.3/juniversalchardet-1.0.3.pom'. > dl.google.com > Could not resolve com.googlecode.juniversalchardet:juniversalchardet:1.0.3. > Could not get resource 'https://jcenter.bintray.com/com/googlecode/juniversalchardet/juniversalchardet/1.0.3/juniversalchardet-1.0.3.pom'. > Could not GET 'https://jcenter.bintray.com/com/googlecode/juniversalchardet/juniversalchardet/1.0.3/juniversalchardet-1.0.3.pom'. > jcenter.bintray.com Could not resolve com.squareup:javapoet:1.8.0. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.squareup:javapoet:1.8.0. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/squareup/javapoet/1.8.0/javapoet-1.8.0.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/squareup/javapoet/1.8.0/javapoet-1.8.0.pom'. > dl.google.com > Could not resolve com.squareup:javapoet:1.8.0. > Could not get resource 'https://jcenter.bintray.com/com/squareup/javapoet/1.8.0/javapoet-1.8.0.pom'. > Could not GET 'https://jcenter.bintray.com/com/squareup/javapoet/1.8.0/javapoet-1.8.0.pom'. > jcenter.bintray.com Could not resolve com.google.code.gson:gson:2.8.5. Required by: project : > com.android.tools.build:gradle:3.5.0 > androidx.databinding:databinding-compiler-common:3.5.0 > Could not resolve com.google.code.gson:gson:2.8.5. > Could not get resource 'https://dl.google.com/dl/android/maven2/com/google/code/gson/gson/2.8.5/gson-2.8.5.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/com/google/code/gson/gson/2.8.5/gson-2.8.5.pom'. > dl.google.com > Could not resolve com.google.code.gson:gson:2.8.5. > Could not get resource 'https://jcenter.bintray.com/com/google/code/gson/gson/2.8.5/gson-2.8.5.pom'. > Could not GET 'https://jcenter.bintray.com/com/google/code/gson/gson/2.8.5/gson-2.8.5.pom'. > jcenter.bintray.com Could not resolve org.jetbrains.kotlin:kotlin-stdlib:1.3.41. Required by: project : > com.android.tools.build:gradle:3.5.0 > org.jetbrains.kotlin:kotlin-stdlib-jdk8:1.3.41 > Could not resolve org.jetbrains.kotlin:kotlin-stdlib:1.3.41. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-stdlib/1.3.41/kotlin-stdlib-1.3.41.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-stdlib/1.3.41/kotlin-stdlib-1.3.41.pom'. > dl.google.com > Could not resolve org.jetbrains.kotlin:kotlin-stdlib:1.3.41. > Could not get resource 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib/1.3.41/kotlin-stdlib-1.3.41.pom'. > Could not GET 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib/1.3.41/kotlin-stdlib-1.3.41.pom'. > jcenter.bintray.com Could not resolve org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.3.41. Required by: project : > com.android.tools.build:gradle:3.5.0 > org.jetbrains.kotlin:kotlin-stdlib-jdk8:1.3.41 > Could not resolve org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.3.41. > Could not get resource 'https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-stdlib-jdk7/1.3.41/kotlin-stdlib-jdk7-1.3.41.pom'. > Could not GET 'https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-stdlib-jdk7/1.3.41/kotlin-stdlib-jdk7-1.3.41.pom'. > dl.google.com > Could not resolve org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.3.41. > Could not get resource 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib-jdk7/1.3.41/kotlin-stdlib-jdk7-1.3.41.pom'. > Could not GET 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib-jdk7/1.3.41/kotlin-stdlib-jdk7-1.3.41.pom'. > jcenter.bintray.com

    • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    • Get more help at https://help.gradle.org

    BUILD FAILED in 1m 10s Exception: Gradle task assembleDebug failed ) exit code 1

    Steps to Reproduce

    1. ..open android studio.
    2. ... then select the play button
    3. ...The errors are shown on the console

    Logs

    C:\src\flutter>flutter doctor Doctor summary (to see all details, run flutter doctor -v): [√] Flutter (Channel stable, v1.12.13+hotfix.9, on Microsoft Windows [Version 10.0.18362.836], locale en-IN)

    [√] Android toolchain - develop for Android devices (Android SDK version 29.0.3) [√] Android Studio (version 3.6) [√] VS Code (version 1.44.2) [√] Connected device (1 available)

    • No issues found!

    C:\src\flutter>flutter doctor Doctor summary (to see all details, run flutter doctor -v): [√] Flutter (Channel stable, v1.12.13+hotfix.9, on Microsoft Windows [Version 10.0.18362.836], locale en-IN)

    [√] Android toolchain - develop for Android devices (Android SDK version 29.0.3) [√] Android Studio (version 3.6) [√] VS Code (version 1.44.2) [√] Connected device (1 available)

    • No issues found!

    opened by kelvin002a 0
  • Can't able open the documents

    Can't able open the documents

    When trying to access documentation, I'm having Your connection isn't private or 404 error. Have tried with different computers. Does anyone have the same issue?

    Same Here..!

    Thank You

    opened by gnnandan7 1
  • Couldn't access the documentation

    Couldn't access the documentation

    When trying to access documentation, I'm having Your connection isn't private or 404 error. Have tried with different computers. Does anyone have the same issue?

    Thanks

    opened by bugrameral 1
  • Clima - Completed Project is broken

    Clima - Completed Project is broken

    This project overall is very busted. geolocator has been updated to a new version that requires quite a bit more work to enable (at least on Android).

    Please fix or replace the project completely.

    opened by TheRealDealLeal 3
Owner
London App Brewery
The Best Programming School in the World
London App Brewery
Learn Dart with this cheat sheet

Learn Dart with this cheat sheet This project starts from Hello World untill the end of the Dart :) Simple example Hello World in Dart void main() {

null 27 Jul 21, 2022
Learn Dart with this cheat sheet

Learn Dart with this cheat sheet This project starts from Hello World untill the end of the Dart :) Simple example Hello World in Dart void main() {

AmirHossein Mohammadi 8 Jan 16, 2022
It says it all. Not In Flutter Docs, a sort of underground guide to flutter app development and design.

Not In Flutter Docs It says it all. Not In Flutter Docs, a sort of underground guide to flutter app development and design. Licenses Code is under BSD

Fred Grott 54 Sep 14, 2022
Highly Subjective Roadmap to Flutter Development

Flutter Roadmap Dev Environment https://learngitbranching.js.org Language https://dart.dev/guides/language/language-tour https://dart.dev/guides/langu

Oleksandr Leuschenko 4k Sep 27, 2022
Flutter tips and tricks to make the development smoother and easier

Table of Contents Custom Clippers in Flutter Check if Website is Up or Down in Dart Section Titles on ListView in Flutter Circular Progress in Flutter

Praharsh Bhatt 16 Apr 1, 2022
A curated list of awesome cheats needed to quickly get started with flutter development.

dart-cheat-sheet A curated list of awesome stuff needed to get started with your flutter development journey Table of Contents String interpolation Fu

Temidayo Adefioye 124 Sep 21, 2022
❤️Flutter ❤️ tips and tricks ❤️ Awesome Flutter ❤️ tips and tricks ❤️

❤️ Awesome Flutter ❤️ tips and tricks ❤️ Tip 1 : stless & stful We can type stless and stful and we get Autocomplete Suggestion to generate Stateless

Laxman Bhattarai 2.8k Sep 30, 2022
🎓Flutter TodoList tutorial

Todo List built with Flutter Built with Git Tutor This tutorial will walk you through the process of building of a simple todo-list with Flutter Getti

Andrei Lesnitsky 280 Sep 12, 2022
Based on Microsoft Fluent Design System and made using the help of Flutter VelocityX.

Vx Fluent UI for Flutter Based on Microsoft Fluent Design System and made using the help of Flutter VelocityX. VxFluentUI is a Flutter component libra

Pawan Kumar 14 Jan 28, 2022
Personal Knowledge Base (PKB). Flutter Responsive Web, Desktop, Android, iOS app. MobX as state management.

PKB - Responsive Flutter Web / Desktop / Android / iOS "Personal Knowledge Base" app written on Flutter. >> View DEMO Video About project This project

Vladimir 20 Sep 2, 2022
Flutter Portfolio App Concept - Day 33

Flutter Portfolio App Concept - Day 33

Mohammad Rahmani 29 Sep 11, 2022
An awesome Flutter 3d project by Flutter_Cube package

flutter3d A new Flutter project. Getting Started This project is a starting point for a Flutter application. A few resources to get you started if thi

Azamatjan 1 Oct 26, 2021
Flutter Tutorial - Speech To Text & Voice Recognition

Flutter Tutorial - Speech To Text & Voice Recognition Let's build a Speech To Text Flutter app which recognizes & analyzes your words to execute comma

null 0 Nov 3, 2021
A Collection of Flutter and Dart Tips and Tricks

A Collection of Flutter and Dart Tips and Tricks

Vandad Nahavandipoor 5.4k Sep 26, 2022
A Flutter implementation of an expandable and animated floating search bar, also known as persistent search.

Material Floating Search Bar A Flutter implementation of an expandable floating search bar, also known as persistent search, similar to the ones used

null 390 Mar 3, 2022
A flexible multi select package for Flutter. Make multi select widgets the way you want.

Multi Select Flutter Multi Select Flutter is a package for creating multi-select widgets in a variety of ways. Dialog BottomSheet ChoiceChip Features

null 167 Sep 22, 2022
Animal Sounds App written in flutter for the #100daysOfCode

animalsounds A new Flutter project. Getting Started This project is a starting point for a Flutter application. A few resources to get you started if

Antonio Giordano 0 Jan 9, 2022
Amazon Bookshelf Interface Design made in Flutter

amazon_ui_clone A new Flutter project. Getting Started This project is a starting point for a Flutter application. A few resources to get you started

Emanoel Santana 0 Nov 25, 2021
A Flutter widget that scrolls text widget and other widget

marquee_widget A Flutter widget that scrolls Widget Text and other Widget with supported RTL. Provides many customizationsincluding custom scroll dire

Yousif Khalid 21 Aug 6, 2021